注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

稀土天使的博客

天使是为稀土衔来橄榄枝的和平鸽

 
 
 

日志

 
 

1250回头望月(主图 源码)  

2013-12-03 21:34:59|  分类: 默认分类 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
 源码如下: 

DRAWTEXT(SYSPARAM(2)=BARPOS,CLOSE,《股海神偷独门暗器指标》:版块:+BLKNAME),ALIGN4,colorFFFF;
DRAWTEXT(SYSPARAM(2)=BARPOS,CLOSE,《联系电话:0539--3226027》证券代码:+STKLABEL),ALIGN5,PXUP4,colorFF00;
VARA:=IF(CLOSE>150,91.3,0.913);
箱下沿:=INTPART(CLOSE/VARA)*VARA;
箱上沿:=箱下沿+VARA;
箱中线:=(箱下沿+箱上沿)/2;
走势:=SMA(FORCAST(CLOSE,18),6,1);
VARE:=1111231;
U1:=IF(DATE<=VARE,1,0);
VAR1:=(HIGH+LOW+OPEN+CLOSE)/4;
操盘线:=(MA(3*VAR1-2*SMA(VAR1,2,1),10))*U1;
十日高:HHV(HIGH,13)*(1-5/100)*U1,LINETHICK2,colorFF0000;
EMA(操盘线,500)*U1,LINETHICK4,colorFF0000;
VAR0:=EMA(EMA(EMA(CLOSE,2),2),2);
MA13:MA(VAR0,13)*U1*0.99,colorFFFF;
MA(VAR0,13)*U1*0.999,colorFFFF;
M21:EMA(VAR0,21)*0.96*U1,LINETHICK3;
M55:=EMA(VAR0,55)*0.96*U1;
M120:EMA(VAR0,120)*U1,LINETHICK4;
M250:EMA(VAR0,250)*0.98*U1,LINETHICK5;
QQ:EMA(EMA(EMA(CLOSE,55),1),250)*U1*0.92;
STICKLINE(CLOSE>OPEN OR CLOSE=OPEN AND CLOSE>REF(CLOSE,1),HIGH,LOW,0.1,0),colorFF;
STICKLINE(CLOSE>OPEN OR CLOSE=OPEN AND CLOSE>REF(CLOSE,1),OPEN,CLOSE,7,1),colorFF;
STICKLINE(CLOSE<OPEN OR CLOSE=OPEN AND CLOSE<=REF(CLOSE,1),HIGH,LOW,0.1,0),colorFFFF00;
STICKLINE(CLOSE<OPEN OR CLOSE=OPEN AND CLOSE<=REF(CLOSE,1),OPEN,CLOSE,7,0),colorFFFF00;
X1:=(CLOSE+LOW+HIGH)/3;
X2:=EMA(X1,6)*U1;
X3:=EMA(X2,5)*U1;
STICKLINE(CROSS(X2,X3),OPEN,CLOSE,6,0),colorFFFF;
EMA13:=EMA(CLOSE,13);
EMA34:=EMA(CLOSE,34);
FR:=BARSLAST(REF(CROSS(EMA34,EMA13),1)) AND CROSS(EMA13,EMA34);
HZ:=EMA(CLOSE,13);
均线148天:=EMA(CLOSE,148);
成本:=SUM(AMOUNT,0)/SUM(VOL,0)/100;
TR1:=MAX(MAX(HIGH-LOW,ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
ATR:=MA(TR1,13);
VAR1:=REF(CLOSE,1)-REF(ATR,1);
生命线:HHV(VAR1,12)*U1,LINETHICK4;
生命线2:HHV(VAR1,7)*U1,LINETHICK1;
VAR1:=1;
MID:=MA(CLOSE,N)*VAR1;
YT:=EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2)*VAR1;
UPPER:=MID+2*STD(CLOSE,N)*VAR1;
LOWER:=MID-2*STD(CLOSE,N)*VAR1;
选中:=IF((UPPER-CLOSE)/CLOSE>0.3 AND (ABS(CLOSE-LOWER))/CLOSE<0.05 AND CLOSE<YT,LOWER*0.9,UPPER*1.09);
VAR2:=IF(CLOSE<=LOWER,LOWER,0);
VAR3:=IF(FILTER(VAR2=LOWER,0),-2,0);
AAA:=VAR3+LOWER;
HHH:=HHV(HIGH,288);
LLL:=LLV(LOW,288);
ZH:=HHH[DATACOUNT];
ZL:=LLL[DATACOUNT];
Q:=(ZH-ZL)/5;
C90%:=(COST(95)-COST(5))/(COST(95)+COST(5))*100;
集中度:=IF(C90%<=18 AND CLOSE<ZH-4*Q,100,0);
ZCB1:=SUMBARS(VOL,CAPITAL*1);
ZCB2:=SUM(COST(10),ZCB1)/ZCB1;
ZCB3:=SUM(COST(20),ZCB1)/ZCB1;
ZCB4:=SUM(COST(30),ZCB1)/ZCB1;
ZCB5:=SUM(COST(40),ZCB1)/ZCB1;
ZCB6:=SUM(COST(50),ZCB1)/ZCB1;
庄本:(5*ZCB2+4*ZCB3+3*ZCB4+2*ZCB5+ZCB6)/15,LINETHICK3,PRECISION2,color808080;
庄本2:(5*ZCB2+4*ZCB3+3*ZCB4+2*ZCB5+ZCB6)/15*1.01,LINETHICK3,PRECISION2,color808080;
X:=1;
LGL:=IF(EMA(CLOSE,5)/EMA(EMA(CLOSE,9),16)<=0.85 AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,50,0);
WR1:=-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100*X;
WR2:=-100*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100;
WR3:=-100*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100*X;
BIAS1:=((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5;
BIAS2:=((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5;
BIAS3:=((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5;
S1:=(WR1+WR2+WR3+BIAS1+BIAS2+BIAS3)/6*X;
S2:=EMA(S1,3);
S3:=ABS(BIAS1-BIAS3);
SX:=(S1+S3)/2;
XC1:=(-1)*(EMA(100*(1-WINNER(CLOSE)),1)-50)+50;
CCC:=XC1+SX;
ZJZ:=(IF(LGL>0 AND CCC<0,200,0))*X;
LXL:=IF(SX<0 AND CLOSE=LLV(CLOSE,5) AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,-50,0);
JBJ:=(IF(CCC<0 AND LXL=-50,100,0))*X;
MA3:=MA(CLOSE,3);
C0:=REF(CLOSE,2)*0.865;
C1:=REF(CLOSE,13)*0.772;
BOT:=MIN(C0,C1);
HSL:=100*VOL/CAPITAL*X;
MA13:=MA(CLOSE,13)*X,colorFFFF;
CXC:=IF((CLOSE-BOT)/CLOSE<12/100 AND SUM(HSL,5)/5<1.8,1,0);
VMC:=IF(CXC>0 AND (LXL<0 OR LGL>0),100,0);
满仓:=VMC;
半:=IF(ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR CXC>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902 OR (ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR CXC>0) AND (LXL<0 OR LGL>0) AND VMC<10,50,0);
V93:=(ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR CXC>0) AND (LXL<0 OR LGL>0);
V90:=ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR CXC>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902;
半仓:=V93 OR V90;
XMM87:=满仓 OR 半仓;
XMM91:=VMC;
初:=MA(CLOSE,80)-MA(CLOSE,10)/3*X;
初级:=IF(XMM87>0,30,0);
中级:=IF(XMM91>0,91,0);
高级:=IF(VMC>0 AND CLOSE<初,97,0);
终结者:=MAX(MAX(高级,初级),中级);
VAR2Q:=MA(CLOSE,80)-MA(CLOSE,13)/3;
神奇线:=MA((CLOSE-VAR2Q)/VAR2Q,1);
买点一:=IF(CROSS(神奇线,0) AND LOW/REF(HIGH,1)<1.012,0.5,0);
稳赚:=IF(COUNT(神奇线>REF(神奇线,1),3)=3 AND COUNT(神奇线<0,10)=10 AND REF(神奇线,3)=LLV(神奇线,10),0.5,0);
买点二:=IF(REF(神奇线,2)=LLV(神奇线,20) AND REF(神奇线,2)<0.071 AND REF(神奇线,2)<REF(神奇线,1) AND NOT(REF(LOW,1)>REF(HIGH,2) AND LOW>REF(HIGH,1)) AND CLOSE>REF(CLOSE,1),0.5,0);
XA:=EMA(神奇线,12)*0.7;
XB:=EMA(神奇线,3);
底部将成:=IF(LLV(XB-XA,30)>0,0,-30);
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
MACD抄底:=IF(底部将成<0 AND CROSS(MACD,0),100,0);
DRAWICON(MACD抄底>0,生命线2,1);
VAR333:=CLOSE>(REF(HIGH,1)+REF(LOW,1))/2;
VAR55:=BARSLAST(VAR333);
VAR93:=IF(VAR55>3,-2,0);
DRAWICON(REF(VAR93,1)=-2 AND VAR93=0,LOW,1),colorFF;
DRAWICON(REF(VAR93,1)=-2 AND VAR93=0,LOW,8),colorFF;
AA1:=AMOUNT/VOL;
BB1:=LOW<AA1*0.9;
CC1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>1.2;
DD1:=LOW<MA(CLOSE,5)*0.921;
EE1:=VOL<MA(VOL,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,LOW*0.99,★),colorFF00;
STICKLINE(FF1,HIGH,LOW,0.5,0),colorFF00;
STICKLINE(FF1,OPEN,CLOSE,6,1),LINETHICK2,colorFF00;
VAR1:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VAR2:=REF(VAR1,1);
VAR3:=(SMA(MAX(VAR1-VAR2,0),10,1))/(SMA(ABS(VAR1-VAR2),10,1))*100;
VAR4:=FILTER(IF(COUNT(VAR3<20,5)>=1 AND COUNT(VAR1=LLV(VAR1,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0),5);
DRAWICON(VAR4,LOW/1.03,6);
Y1:=EMA(EMA(CLOSE,5),5);
Y2:=HHV(MA(HIGH,13),13);
VAR5:=FILTER(Y1>REF(Y1,1) AND Y2<REF(Y2,1) AND CLOSE>REF(CLOSE,1),11);
DRAWTEXT(VAR5,LOW/1.02,追涨 ),colorFF00;
DRAWICON(VAR5,LOW/1.03,12);
X1:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
X2:=EMA(0.667*REF(X1,1)+0.333*X1,5);
DRAWICON(IF(VOL>=1.3*MA(VOL,5) AND COUNT(X1>=X2 AND X1<-17,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW/1.01,4);
VAR1:=1;
MID:=MA(CLOSE,N)*VAR1;
YT:=EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2)*VAR1;
UPPER:=MID+2*STD(CLOSE,13)*VAR1;
LOWER:=MID-2*STD(CLOSE,13)*VAR1;
选中:=IF((UPPER-CLOSE)/CLOSE>0.3 AND (ABS(CLOSE-LOWER))/CLOSE<0.05 AND CLOSE<YT,LOWER*0.9,UPPER*1.09);
VAR2:=IF(CLOSE<=LOWER,LOWER,0);
VAR3:=IF(FILTER(VAR2=LOWER,0),-2,0);
AAA:=VAR3+LOWER;
CCCC2:=IF(AAA<LOWER OR 选中<LOWER,80,100);
DRAWTEXT(选中<LOWER,CLOSE*0.92,●),PXUP6,color4600FF;

1250回头望月(主图 源码) - 稀土天使 - 稀土天使的博客


  评论这张
 
阅读(369)| 评论(2)
推荐

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017